Recent Changes - Search:

Disclaimer

edit SideBar

Install Gilda VMs on VMware

1.  Install GILDA VM image on VMware server 2.0

# rpm -ivh VMware-server-2.0.0-122956.x86_64.rpm
# /usr/bin/vmware-config.pl
In which directory do you want to keep your virtual machine files? 
[/var/lib/vmware/Virtual Machines] /dsk2/VMware_VMs

# cd /dsk2/VMware_VMs
# tar jxvf ../GILDA_VMimages/GILDAVM_Base_SLC4.6_i386.tar.bz2 
# cp -r GILDAVM_Base_SLC4.6_i386 glite-ce_SLC46_i386
# cd glite-ce_SLC46_i386
# mv SLC46-i386.vmx glite-ce_SLC46_i386.vmx
# vi glite-ce_SLC46_i386.vmx
...
displayName = "glite-ce_SLC46_i386"
memsize = "512"
ethernet0.generatedAddress = "00:0c:29:a3:01:01"
ethernet0.connectionType = "bridged"
...
# yum install fuse fuse-libs # needed for vmware-mount
# vmware-mount -p SLC46-i386.vmdk
Nr      Start       Size Type Id Sytem                   
-- ---------- ---------- ---- -- ------------------------
 1         63   61432497 BIOS 83 Linux
 2   61432560    4192965 BIOS 82 Linux swap
 3   65625525  102141270 BIOS 83 Linux
# mkdir /mnt/t
# vmware-mount  SLC46-i386.vmdk 3 /mnt/t
mount: you must specify the filesystem type
Failed to mount partition 3 of disk 'SLC46-i386.vmdk' on '/mnt/t': A loop device operation failed
# vmware-mount SLC46-i386.vmdk /mnt/t
# mount
/dev/loop0 on /mnt/t type ext3 (rw)
# #funny, it worked without specifying the partition!!
# cd /mnt/t/etc/sysconfig/network-scripts
# cat ifcfg-eth0 
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=dhcp
# cat /etc/sysconfig/network-scripts/ifcfg-eth0 
DEVICE=eth0
BOOTPROTO=none
BROADCAST=152.106.18.255
HWADDR=00:22:19:8E:1B:8D
IPADDR=152.106.18.254
NETMASK=255.255.255.0
NETWORK=152.106.18.0
ONBOOT=yes
TYPE=Ethernet
USERCTL=no
IPV6INIT=no
PEERDNS=yes
GATEWAY=152.106.18.1
# vi ifcfg-eth0
# cat ifcfg-eth0 
DEVICE=eth0
BOOTPROTO=none
BROADCAST=152.106.18.255
IPADDR=152.106.18.253
NETMASK=255.255.255.0
NETWORK=152.106.18.0
ONBOOT=yes
TYPE=Ethernet
USERCTL=no
IPV6INIT=no
PEERDNS=yes
GATEWAY=152.106.18.1
# umount /mnt/t
# vmrun -h http://localhost:8222/sdk -u root -p******** start /dsk2/VMware_VMs/glite-ce_SLC46_i386/glite-ce_SLC46_i386.vmx 
Error: Insufficient permissions in host operating system
# vmrun -h http://localhost:8222/sdk -u root -p ******** start /dsk2/VMware_VMs/glite-ce_SLC46_i386/glite-ce_SLC46_i386.vmx 
Error: Cannot open VM: /dsk2/VMware_VMs/glite-ce_SLC46_i386/glite-ce_SLC46_i386.vmx, The virtual machine cannot be found
# ls /dsk2/VMware_VMs/glite-ce_SLC46_i386/glite-ce_SLC46_i386.vmx
/dsk2/VMware_VMs/glite-ce_SLC46_i386/glite-ce_SLC46_i386.vmx
# ## so, it is there! ???
# vmrun -h http://localhost:8222/sdk -u root -p ******** start /dsk2/VMware_VMs/GILDAVM_Base_SLC4.6_i386/SLC46-i386.vmx 
Error: Cannot open VM: /dsk2/VMware_VMs/GILDAVM_Base_SLC4.6_i386/SLC46-i386.vmx, The virtual machine cannot be found

same thing... something is mixed up, I can't even run vmware-config - time to go to sleep..

#vmrun -h http://localhost:8222/sdk -u root -p ******** register /dsk2/VMware_VMs/glite-ce_SLC46_i386/glite-ce_SLC46_i386.vmx 
Error: The virtual machine cannot be found
# vmrun -h http://localhost:8222/sdk -u root -p ******** register "[standard] /glite-ce_SLC46_i386/glite-ce_SLC46_i386.vmx"
# vmrun -h http://localhost:8222/sdk -u root -p ******** listRegisteredVM
Total registered VMs: 1
[standard] glite-ce_SLC46_i386/glite-ce_SLC46_i386.vmx
# vmrun -h http://localhost:8222/sdk -u root -p ******** start "[standard] /glite-ce_SLC46_i386/glite-ce_SLC46_i386.vmx"
Error: Cannot open VM: [standard] /glite-ce_SLC46_i386/glite-ce_SLC46_i386.vmx, The virtual machine cannot be found
# vmrun -h http://localhost:8222/sdk -u root -p ******** start "[standard] glite-ce_SLC46_i386/glite-ce_SLC46_i386.vmx"
# ## YESS!!!
# ping 152.106.18.253
PING 152.106.18.253 (152.106.18.253) 56(84) bytes of data.
64 bytes from 152.106.18.253: icmp_seq=0 ttl=64 time=1.77 ms
# ssh root@152.106.18.253
# ## yay!!
# passwd
# ## change root passwd immediately
# ping 152.106.18.2
PING 152.106.18.2 (152.106.18.2) 56(84) bytes of data.
64 bytes from 152.106.18.2: icmp_seq=0 ttl=64 time=0.894 ms
# ## net is up!

Ok, now configure:

/etc/hosts
/etc/resolv.conf
/etc/sudoers
TENET-sl46-errata.repo
TENET-sl46.repo
Edit - History - Print - Recent Changes - Search
Page last modified on March 27, 2009, at 12:43 PM